57 lines
1.3 KiB
Nix
Executable File
57 lines
1.3 KiB
Nix
Executable File
{
|
|
description = "NixOS Hosts";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:NixOS/nixpkgs/nixos-24.11";
|
|
disko.url = "github:nix-community/disko";
|
|
snowfall-lib = {
|
|
url = "github:snowfallorg/lib";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
home-manager = {
|
|
url = "github:nix-community/home-manager/release-24.11";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
apple-silicon = {
|
|
url = "github:tpwrules/nixos-apple-silicon/releasep2-2024-12-25";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
nixos-generators = {
|
|
url = "github:nix-community/nixos-generators";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
firefox-addons = {
|
|
url = "gitlab:rycee/nur-expressions?dir=pkgs/firefox-addons";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
sops-nix = {
|
|
url = "github:Mic92/sops-nix";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
};
|
|
|
|
outputs = inputs:
|
|
inputs.snowfall-lib.mkFlake {
|
|
inherit inputs;
|
|
src = ./.;
|
|
|
|
snowfall = {
|
|
namespace = "reichard";
|
|
meta = {
|
|
title = "Reichard";
|
|
name = "reichard";
|
|
};
|
|
};
|
|
|
|
homes.modules = with inputs; [
|
|
sops-nix.homeManagerModules.sops
|
|
];
|
|
|
|
systems.modules = {
|
|
nixos = with inputs; [
|
|
sops-nix.nixosModules.sops
|
|
];
|
|
};
|
|
};
|
|
}
|